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Abstract: The increasing frequency of ATM-related crimes, including theft, vandalism, and unauthorized access,
necessitates the development of advanced security solutions. This paper proposes an loT-enabled Smart ATM Security
System that integrates an ESP32 microcontroller, GSM module, IR sensors, touch sensor, motor driver with DC motor,
LCD display, buzzer, and battery backup. The system employs multi-layered security: IR sensors monitor human
presence near the ATM entrance, the touch sensor detects tampering attempts, and the GSM module provides real-time
SMS alerts to bank authorities. A motorized door mechanism ensures restricted access, while an LCD display
communicates system status. The design was implemented using Arduino IDE and Embedded C programming.
Experimental testing under various scenarios demonstrated rapid response time, high reliability, and uninterrupted
operation during power failures. The proposed system offers a cost-effective, scalable, and efficient solution for ATM
security.
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I INTRODUCTION

Automated Teller Machines (ATMs) are essential components of modern banking systems, providing customers 24/7
access to financial services. However, ATMs are also common targets for crimes such as physical break-ins, theft,
vandalism, and tampering with cash dispensers. Traditional methods of ATM security include CCTV surveillance,
mechanical locks, and security guards. While these measures help monitor activities, they often lack the ability to respond
proactively in real time. Recent advancements in the Internet of Things (IoT) have enabled the design of intelligent
systems capable of monitoring, detecting, and responding automatically to suspicious activities. By integrating sensors,
microcontrollers, and wireless communication modules, ATM security can be made more robust, responsive, and cost-
effective. This paper presents a Smart ATM Security System using ESP32 as the main controller, combined with IR
sensors, touch sensor, GSM module, motor driver, and buzzer. The proposed system improves security by detecting
human presence, preventing tampering, and notifying authorities immediately through GSM communication.

I1. OBJECTIVES

The objectives of the project:
e To design and implement a smart ATM security system using ESP32 microcontroller.
e To use a touch sensor for tamper detection.
e To employ a GSM module for real-time SMS alerting to bank officials.

1. METHODOLOGY
A. BLOCK DIAGRAM
The ESP32 microcontroller is the central unit that controls the system. The IR sensor detects human presence near the
ATM, while the touch sensor identifies tampering attempts. A power supply provides stable operation. The ESP32
communicates with an LCD display (via 12C) to show system status, and it controls a buzzer for audible alerts. A GSM

module sends SMS notifications to the bank in case of suspicious activity. The DC motor operates the ATM door,
allowing or restricting access. Together, these components form a smart, loT-based ATM security solution..
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Figure 1. Block Diagram of Smart ATM Security System

B. FLOW CHART

The system begins with initialization. IR Sensor 1 detects human presence to open the door and closes it once the user
enters. Inside, the touch sensor checks for tampering. If tampering occurs, the GSM module sends alerts to the bank and
police, and the buzzer activates. Otherwise, IR Sensor 2 monitors the user’s exit, opens the door, and closes it after the
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Figure 2 Flow Diagram of Smart ATM Security System
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Iv. HARDWARE DESCRIPTION

4.1 ESP 32 Development Board
The ESP32 is a low-cost, low-power microcontroller with built-in Wi-Fi and Bluetooth. It acts as the central processing
unit, receiving inputs from sensors and controlling outputs such as the motor, buzzer, and LCD display.

Figure 3 ESP32 Development Board

The device features a dual-core Xtensa LX6 microprocessor, built-in Wi-Fi and Bluetooth v4.2, with up to 34 GPIO pins,
520 KB SRAM and 4 MB Flash memory, operating voltage between 3.0V — 3.3V, and supports various protocols like
UART, SPI, 12C, 12S, PWM, ADC, DAC, and CAN.

4.2 IR Sensor
IR sensors are used near the ATM entrance to detect human presence. They trigger the ESP32 to either allow access or
keep the door locked.

Figure 4 IR Sensor

4.3 Touch Sensor
The touch sensor detects unauthorized tampering attempts with ATM hardware. When activated, it triggers the GSM
module to send an SMS alert and activates the buzzer.

Figure 5 Touch Sensor

4.4 Motor and Motor Driver: The motor driver controls the DC motor for automated locking/unlocking of the ATM room
door.

MOTOR A MOTOR B
out outa e
out2 outs d
-
JUMPER e
Figure 6 Motor Driver Figure 7 DC Motor
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4.5 GSM Module: The GSM module provides real-time communication by sending SMS alerts to bank authorities when
suspicious activity is detected.

Figure 8 GSM Module

4.6 LCD Display: The LCD screen displays system status such as “Access Granted,” “Access Denied,” or “Tamper
Detected.

Figure 9 LCD Display

4.7 Buzzer: The buzzer provides an audible alert in the case of tampering or unauthorized access.

Figure 10 Buzzer

4.8 Power Supply with Battery Backup: The system is powered by a regulated power supply with battery backup,
ensuring continuous operation even during power failures.

1713OwINa I

Figure 11 Battery
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V. SCHEMATIC DIAGRAM

The schematic diagram illustrates the working of the Smart ATM Security System. The ESP32 microcontroller acts as
the central unit, connected to IR sensors for human presence detection and a touch sensor for tamper detection. An LCD
display, interfaced through I2C, shows the system status such as entry or occupancy. The GSM module is used to send
SMS alerts to bank authorities in case of suspicious activity. A buzzer is connected to provide audible alarms, while a
DC motor controlled by the L298N driver operates the ATM door locking and unlocking mechanism. The entire system
is powered by a battery, ensuring smooth and uninterrupted operation even during power failures.
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Figure 7 Schematic of Voice Assistant Home Automation
VI. SOFTWARE DESCRIPTION

6.1 ESP32 with Arduino IDE

For ESP32 Programming, we can use Arduino IDE. Open the Arduino IDE and go to File » Preference as shown in the
Figure 8 Then on the Preference window as shown in Figure 9, enter the below link in Additional Boards Manager URLs
https://raw.githubusercontent.com/espressif/arduino-esp32/gh- pages/package esp32 index.json.Then click on OK
button.

sketch_jun21a | Arduino 1.8.19

Preferences X

FileJEdit Sketch Tools Help Settings Network
New Ctrl+N Sketchbook location:
C:\Users\Shree\Documents\Arduino Browse
Open... Ctrl+O
> Editor language: System Default ~ (requires restart of Arduino)
Open Recent 2 Editor font size: 12
Sketchbook > Interface scale: (] Automatic | 100 % %  (requires restart of Arduino)
Examples > Theme: Default theme ~  (requires restart of Arduino)
Show verbose output during: || compllation [ | upload
Close Ctrl+W
Compller warnings: None v
Save Ctrl+S [v] Display line numbers [ ] Enable Code Folding
Save As... Ctrl+Shift+S [ Verify code after upload [ Juse external editor
[v] Check for updates on startup [v]Save when verifying or uploading
Page Setup  Ctrl+Shift+P [ Juse accessibility features
- Additional Boards Manager URLS:  https://raw. Jes) esp32/gh-pages,
Print Ctrl+P L T - - cl
e edited directly In the file
\AppData\Local\Ardulno15\preferences.txt
| Preferences ctri+Comma | aymisssmnin
‘ Quit ctrl+Q O eaolyl |
Figure 8 File bar Figure 9 Preference window
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To add the ESP32 board, go to the path Tools » Board » Boards Manager in Figure 10(a). Then, type on esp32 on the
search bar and click on the install button in Figure 10(b). Wait for installation window as shown in Figure 10(c)

@ sketch jun21a | Arduino 1.8.19
File Edit Sketc

elp

Auto Format Ctrl+T
Archive Sketch

Fix Encoding & Reload

Manage Libraries... Ctrl+Shift+]
Serial Monitor Ctrl+Shift+M
Serial Plotter Ctrl#Shift+L

WiFi101 / WIFiNINA Firmware Updater

looy

3¢ Vol. 13, Issue 8, August 2025

© Boards Manager X
Tye Al v e < Type esp32

e Click on Install ~
by Espressif Systems

Boards included in this package:
ESP32 Dev Board, ESP32-52 Dev Board, ESP32-53 Dev Board, ESP32-C3 Dev Board,
More nfo

/1 l;u{ Board: *Arduino Uno* ’l

Port )
Get Board Info

Programmer: "AVRISP mkil* )
Burn Bootloader

Figure 10(a)

)

s <[]

Close

Figure 10(b)

@ Boards Manager

Type |All

esp32
by Espressif Systems
Boards included in this package:

More Info

Downloading boards definitions. Downloaded 4,275kb of 246,542kb.

Figure 10 (c)

ESP32 Dev Board, ESP32-S2 Dev Board, ESP32-53 Dev Board, ESP32-C3 Dev Board.

Installing...

Cancel

After board installation select the ESP32 board using the path Tools » Board » ESP32 Arduino » DOIT ESP32

DEVKIT V1 as shown in Figure 11(a) and then Select the COM Port using Tools » Port » COM* path. In our computer,
the ESP32°s COM port shows COMS as shown in Figure 11(b).
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Figure 11 (a)
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Archive Sketch
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WiFi101 / WIFIiNINA Firmware Updater

void »OF
/7 put Board: "DOIT ESP32 DEVKIT V1~

>
Upload Speed: "921600" >
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Programmer
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Figure 11(b)

6.2 Arduino IDE for Software Development

In Arduino IDE, navigate the mouse cursor to the Tools bar. Then click on Tool bar menu then select in Arduino then we
need to use ESP — 32. Among the list shown in figure select the Which ESP board you going to use. Then go to
Preferences. Select the Path and use the link which is given ashttps://dl.espressif.com/dl/package esp32_index.json
Double click the Boards Manager. Type ESP32 select 2nd one over there and install them.

VIL ESULTS AND DISCUSSION

The system reliably detected human presence using IR and PIR sensors, enabling controlled ATM access. The LCD
displayed “Enter ATM” when vacant and “4TM Busy” when occupied. The touch sensor effectively identified tampering,
triggering the buzzer for local alert and the GSM module for remote SMS notification. The DC motor with L298N driver
accurately handled door locking/unlocking, and the entire system functioned smoothly even under battery backup,
ensuring uninterrupted security
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Figure 13 Smart ATM Security System Model

VIII. APPLICATIONS

Some of the applications are:
1. Bank ATMs in urban and remote areas.
2. Mobile ATMs (e.g., vans).
3.  ATMs in malls, railway stations, and airports.
4. High-security financial premises.

IX. ADVANTAGES

Main advantages of our project are:

1. Real-time alerts to bank officials via GSM.
Multi-layered security with sensors and door automation.
Low-cost and scalable system.

Battery backup ensures continuous operation.
Easy integration with existing ATM infrastructure.

Rl

X. LIMITATIONS

Some of the limitations are:
1.  GSM-based alerting depends on network coverage.
2. Does not authenticate users (no biometric/facial recognition).
3. Limited to sensor-based detection; advanced threats may bypass.

XI. FUTURE SCOPE

Integration with biometric or facial recognition systems for access control.
Development of a mobile app for real-time monitoring.

Cloud storage of activity logs.

AI/ML-based threat prediction and anomaly detection.

=

XII. CONCLUSION

The proposed IoT-based Smart ATM Security System provides an effective and reliable solution to enhance ATM
security. By integrating ESP32, IR sensors, touch sensor, GSM alerts, motorized door control, LCD display, and buzzer,
the system ensures proactive detection and immediate response. The system is cost-effective, scalable, and suitable for
deployment in both rural and urban banking environments. With future enhancements, it can be expanded into a
comprehensive smart security solution for financial institutions.
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